Updating content has encountered problem

An error occurred while collecting iterms to be installed When I asked for details it gave me a list of a zillion lines like this: An error occurred while collecting items to be installed session context was:(profile=_home_c_eclipse_cpp-neon_eclipse, phase=org.eclipse.equinox.internal.p2.engine.phases. No repository found containing: osgi.bundle,org.eclipse.cdt,9.2.1.201704050430 No repository found containing: osgi.bundle,org.autotools.core,2.0.0.201704050430 No repository found containing: osgi.bundle,org.autotools.docs,2.0.2.201704050430 . I did find these four items from Friday at PM, which was like 9 hours before I tried to do the update. Default Client Connection Connection(Default Client Connection Operator.java:159) at org.

Most of today's entries in the Error Log are the same as above. Default Client Connection Operator.resolve Hostname(Default Client Connection Operator.java:259) at org.

Default Request Director.execute(Default Request Director.java:446) at org.impl.client.

updating content has encountered problem-69updating content has encountered problem-43

It turned out that some sites somehow had that problem, but not every Eclipse update site. w=584" class="size-full wp-image-15259" src="https://mcuoneclipse.files.wordpress.com/2015/06/disabled-contact-all-update-sites-during-install-to-finid-required-software.png? w=584&h=468" alt="Disabled Contact all update sites during install to finid required software" width="584" height="468" srcset="https://mcuoneclipse.files.wordpress.com/2015/06/disabled-contact-all-update-sites-during-install-to-finid-required-software.png?

But what helped was to disable the option ‘Contact all update sites during install to find required software‘: Disabled Contact all update sites during install to finid required software " data-medium-file="https://mcuoneclipse.files.wordpress.com/2015/06/disabled-contact-all-update-sites-during-install-to-finid-required-software.png? w=300" data-large-file="https://mcuoneclipse.files.wordpress.com/2015/06/disabled-contact-all-update-sites-during-install-to-finid-required-software.png? w=584&h=468 584w, https://mcuoneclipse.files.wordpress.com/2015/06/disabled-contact-all-update-sites-during-install-to-finid-required-software.png? w=150&h=120 150w, https://mcuoneclipse.files.wordpress.com/2015/06/disabled-contact-all-update-sites-during-install-to-finid-required-software.png? w=300&h=240 300w, https://mcuoneclipse.files.wordpress.com/2015/06/disabled-contact-all-update-sites-during-install-to-finid-required-software.png? w=768&h=615 768w, https://mcuoneclipse.files.wordpress.com/2015/06/779w" sizes="(max-width: 584px) 100vw, 584px" /“), but as well to fix some strange installation problems too :-).

Please keep in mind that you shouldn't use an update site for an Eclipse version that DOES NOT match your installed Eclipse base version.issuetracker.springsource.com/browse/STS-2334 "The url is for an eclipse update site. Update: This is for version 3.8.1 in C:\Users\\Documents\New\STS at this location and when I update I didn't have any issues.

When you access it directly, you will get the 403 error, but Eclipse/STS knows how to access it properly." - not for me... From the STS download site (https://spring.io/tools/sts/all), I got the current update site link which under Update Sites: Go to - Add this link in the Work with field and enter. If you install (unzip) STS in C directly may be then you might have this issue.

System Default Dns Resolver.resolve(System Default Dns Resolver.java:44) at org.

Default Request Connect(Default Request Director.java:611) at org.impl.client.**An error occurred while collecting items to be installed session context was:(profile=Default Profile, phase=org.eclipse.equinox.internal.p2.engine.phases. No repository found containing: osgi.bundle,org.eclipse.commons.quicksearch,3.6.1.201408250654-RELEASE No repository found containing: osgi.bundle,org.springsource.sts,3.6.1.201408250824-RELEASE No repository found containing: org.eclipse.update.feature,org.eclipse.commons.quicksearch.feature,3.6.1.201408250654-RELEASE No repository found containing: org.eclipse.update.feature,org.springsource.sts,3.6.1.201408250824-RELEASE No repository found containing: binary,org.ide.executable.win32.win32.x86_64,3.6.1.201408250824-RELEASE-e43 No repository found containing: org.eclipse.update.feature,org.package,3.6.1.201408250824-RELEASE-e43 No repository found containing: binary,org.package_root,3.6.1.201408250824-RELEASE-e43** Sorry, what if none of these steps resolve the issue?I have flushed the cache as you say, uncheck the Kepler repository from the Available Sites cause my Eclipse is 4.4 (Luna) and yet it is not working.Check for Updates and you should now see all the updates except the one that says Spring Tool Suite. If you choose to re-install, it's better to install in Documents or if you have any other drive than C:\ to avoid such issues and spending time resolving it.Although the question asked is for 3.6.1 I think it's for all versions.The error is more of an annoyance - the debugger proceeds normally after clicking OK.

Tags: , ,